Supported browsers

We support the current and previous major releases of the following browsers:

For the best site experience, we recommend downloading the latest version from any of the sites listed above.

Each time a new browser version is released, we begin supporting that version and stop supporting the third most recent version. For example, if the current version of Internet Explorer is 11, we support Internet Explorer 11 and Internet Explorer 10.

Internet Explorer 9 users: With the release of Internet Explorer 11 on 17/10/13, Internet Explorer 9 is no longer a supported browser version.

Using older browser versions can prevent you from accessing Macat, and some site features won't function as expected. Using the latest browsers also provide better encryption and privacy support.

If a site feature still doesn't work as expected:

Have more questions? Submit a request

Comments